[VIM] StaticStore vendor ACK of XSS issue (CVE-2005-4284)

Steven M. Christey coley at mitre.org
Sat Dec 17 13:53:18 EST 2005

After a bit of confusion, the vendor has now acknowledged the
search.cgi XSS issue:

   The vulnerability has been corrected...  thank you for bringing
   that to our attention and the patched "search.cgi" has been emailed
   to all customers and posted for download on our private forums.

- Steve

Name: CVE-2005-4284
Status: Candidate
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4284
Reference: MISC:http://pridels.blogspot.com/2005/12/staticstore-search-engine-friendly-e.html
Reference: BID:15895
Reference: URL:http://www.securityfocus.com/bid/15895
Reference: FRSIRT:ADV-2005-2915
Reference: URL:http://www.frsirt.com/english/advisories/2005/2915
Reference: SECUNIA:18037
Reference: URL:http://secunia.com/advisories/18037

Cross-site scripting (XSS) vulnerability in StaticStore Search Engine
1.189A and earlier allows remote attackers to inject arbitrary web
script or HTML via unspecified parameters to search.cgi, possibly the
keywords parameter.  NOTE: this issue was originally disputed by the
vendor, but it has since been acknowledged.

More information about the VIM mailing list